APPENDIX E

Mapping and Monitoring
Mangrove Forests with
Radar Remote Sensing -
Chapter 6 Training Module

Required open-source software and libaries:
«  QGIS, SNAP, GDAL

Freely-available sources of radar data:
+ ALOSPALSAR-1 (images and mosaics)

« ALOS PALSAR -2 (mosaic only; images available
via proposal)

*  JERS-1 Mosaics

+ Sentinel-1 a/b (images)

In this tutorial, we will process and analyze radar
images, monitor land use change, and estimate abo-
veground biomass in mangrove forests. There are a few
steps required before we can proceed, which include in-
stalling the necessary software and finding data sources.

1 INSTALLING STEP/SNAP SOFTWARE

First, we need to find, download and install the Sen-
tinel Application Platform (SNAP) software, which is the
main tool used for this tutorial. SNAP is distributed free-
ly by the European Space Agency (ESA) and can be used
to process various types of data including Sentinel-1 and
-2, Radarsat, TerraSAR-X, ALOS/PALSAR-1 and -2, among
others. Data can be processed from level 1 (i.e. Single
Look Complex data) to level 2 (e.g. terrain projected) to
level 3 (e.g. land cover lassification) and polarimetric
decomposition.

The SNAP software can be found here: hitp://
step.esa.int/main/download/ and it is recommend-
ed to read info as the software is regularly updated.
The page should look like Figure 1.1. Find more in-
formation here: http:/step.esa.int/main/toolboxes/
snap/ and here: STEP: http://step.esa.int/main/. Se-
lect the binary installer appropriate to your operating
system (i.e. Windows, Mac OSX or UNIX).

2 FIND AND OBTAIN ALOS DATA
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Figure 1.1 ESA browser page with access to SNAP software downloads.

already been radiometrically calibrated, terrain cor-

We will begin this tutorial with science-ready ~rected and ground projected. JAXA also produces

radar data which were processed by the Japanese
space agency (JAXA). JAXA produced radar mosaics
for each of its spaceborne radar missions: JERS-1
(1996), ALOS-1-PALSAR (2007-2010) and ALOS-2
(2014-20170). The data is science-ready and has

forest/non-forest maps for each year that can be
used to monitor forest disturbances. The steps be-
low show where to find the data and register as a
user. The following section explains how to select
and download the data.
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2.1 JAXA Website Registration

The radar mosaics can be obtained from the JAXA
website; however, it is first required to register in order
to access and download data. Itis free to register. Follow
the steps below:

1. Access JAXA website and register here: http://www.

eorcjaxa,jp/ALOS/en/palsar_fnf/inf_index.htm, ~ then
follow the instructions, including confirming your email.

2. Once registered, click on "Dataset" on the left-hand

side:  http://www.eorc.jaxa.jp/ALOS/en/dataset/data-
set_index.htm

+ (lickon “Global PALSAR-2/PALSAR/JERS-1 Mosaic
and Forest/Non-Forest map." Scroll down to “4.
Download” and click on http://www.eorc.jaxa.jp/
ALOS/en/palsar_fnf/data/index.htm, and log in
using your email and password created during the
registration process.

2.2 Downloading JAXA ALOS Mosaics

In this section, we will select and download radar
mosaics from the JAXA website (Figure 1.2). You will
find global mosaics from JERS-1 for year 1996. JERS-1
was an L-band, HH-only instrument that collected data
from 1992-1998. However, in order to obtain global cov-
erage JAXA had to use data from the full lifetime of the
mission to produce a ~1996 mosaic. This dataset pro-
vides the oldest L-band radar-based global observation
of the Earth, serving as a baseline for temporal analysis
of land use.

For the most recent spaceborne L-band radar
missions (ALOS-1 and ALOS-2), JAXA generates yearly
PALSAR mosaics for 2007, 2008, 2009 and 2010 and
PALSAR-2 mosaics for 2015, 2016, 2017, and soon 2018.
The ALOS mosaics are distributed with dual polarization,
HH and HV, which are ideal for monitoring wetlands and
forests respectively. Indeed, the HH polarization exhib-
its a strong double-bounce effect in inundated wetlands,
while HV is the best polarization configuration to map
and monitor forest cover and above ground biomass.
It is important to note the mosaic tiles are constructed
from multiple radar images that were not acquired at the
same time. As such, the mosaics will not represent, for
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Figure 1.2 Desktop version of the JAXA website
with access to mosaic downloads. You must
first register as a user to access the data.

Figure 1.3 JAXA page with access to all available
yearly radar mosaics.

Figure 1.4 Large scale grid cells of the 2017 ALOS-2 mosaic are displayed. Clicking on a given cell zooms
in to a finer grid. Only the 1°x1° cells can be downloaded.

example, the state of inundation at its maximum annual
extent. However, they provide a useful snapshot.

Click on - http://www.eorc.jaxa.jp/ALOS/en/palsar
fnf/data/index.htm to see a page (Figure 1.3) showing
all available mosaics.

For example, we can select the ALOS/PALSAR-1 Mo-
saicfor 2017. Clicking on the link will lead you to another
page (Figure 1.4) in the browser with a large-scale
grid. You can reach your region of interest by dlicking on

its grid cell location until the cell is Tox1o. The mosaics
are distributed by 1°x1° tiles. To generate a larger mosa-
ic, you must download several 1°x1° tiles which can be
merged using gdal tools or QGIS. Here are the steps:

1. Click on your region of interest. (In this work-
shop, this will be Kenya’s coast)

2. (ick until you end-up at the desired location.
Note that all mosaic grid-cells are 1ex1°.
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2.3 Downloading 1-degree cells

For PALSAR-T and PALSAR-2, there are 3 mosaics
(see Figure 1.5).

1.1 ENF: Forest vs. Non-Forest map (See M.
Shimada, T. Itoh, T. Motooka, M. Watanabe, T.
Shiraishi, R. Thapa, and R. Lucas, “New global
forest/non-forest maps from ALOS PALSAR data
(2007—2010) " Remote Sens. Environ., vol. 155,
pp. 13-31, 2014)

1.2 HH. Mosaic of Horizontal-transmit and Hor-
izontal-receive polarization. Sensitive to both
volume and surface. Excellent for monitoring
wetlands, forest-inundations, urban infrastruc
ture and expansion.

1.3 HV: Mosaic of Horizontal-transmit and Ver-
tical-receive polarization. Sensitive to volumes
such as vegetation density. Excellent to distin-
guish and monitor forests.

Download a file by clicking on the “Download”
icon. The file will automatically download to com-
puter as zipped file; for HH and HV this will be about
65MB. Then you can unzip the files, typically with a
double-click on file. The Tox1o tiles are in an ENVI
format that can be opened in ENVI or QGIS. To view
in QGIS, you can simply drag-and-drop the file in
the main QGIS window. As an alternative, you can
also use the “gdal_translate” command in a termi-
nal window to convert in any format using option
"-of Gtiff".

3 DOWNLOAD RAW ALOS/PALSAR-1 DATA

In this section, we will find and download raw
images from the ALOS/PALSAR-1 instrument. To
date (2018), the ALOS/PALSAR-2 data is only avail-
able via a proposal process or purchase. Other ra-
dar datasets, such as ALOS-1, are available through
the ASF Vertex interface (Figure 1.6).

3.1 3.1 Searching for radar images in a
specific location and within a time period

The steps below describe how to obtain data from
the Alaska Satellite Facility (ASF) website; specifically,

we can find ALOS/PALSAR-1 data acquired between
2007 and 2010. We will select a small region of interest
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Figure 1.5 JAXA's website showing selected 1°x1° tiles over Kenya’s coast.

over Kenya's coast. The list of data found by ASF's Vertex
tool matching your selection criteria will appear in the
right-hand side of the interface, with clickable thumbnail
images to help in the selection of data. Here is how to
search for data:

1. Go to the Alaska Satellite Facility Vertex interface:
https://vertex.daac.asf.alaska.edu/

2. Click on “Geographic Search,” and follow the in-
structions to regjster to create a (free) account.

3. Go back to the site and log in. Click and drag your
cursor from the top left of your study site to the bot-
tom right. A box will be drawn around your selected
area. These coordinates will be written automatically
in the “Geographic Region” tab.

4. Enter range of dates for which you seek data. For

PALSAR-1, this will be between 2007 and 2010. The
“Path” and “Frame” are optional.

5. Click “Search” at the bottom.

Once we have clicked on the “Search” button, the
Vertex tool will search for data matching the select-
ed criteria. A list of files will appear on the right with
low-resolution thumbnail preview images (Figure 1.7).
You will notice that files with different imaging modes
will be available:

1.1 “WB1" is (ScanSAR) Wide-Beam #1

1.2 PLR is afully polarimetric dataset with HH,
HVand Vv

1.3 FBD is Fine-Beam Dual polarization includ-
ing HH and HV.

1.4 FBS is Fine-Beam Single polarization (HH)
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Figure 1.6 The ASF Vertex interface.

More details on the characteristics of ALOS/PAL-
SAR imaging modes can be found in Table 1. In our
example, high resolution ascending-orbit images are
available, along with WB1 descending-orbit images.
Ascending and descending mean the targets are seen
from the West and East respectively. A single-click on
the thumbnail images will highlight the location of each
image within the Vertex's maps.

3.2 Select Data

To obtain additional information for each image,
click on the “Details” button below any thumbnail.
To download an image, click on the “Queue” button.
A dropdown menu will appear with options of Lev-
el 1.0, 1.1, 1.5, or radiometrically terrain-corrected
(RTQ). The available options depend on the radar
imaging mode (Table 1). Try it out. The option to be
selected (Table 2) depends on your objectives and
your level of expertise. Typically, for most processing
performed in SNAP, you will need the SLC project-
ed images, which SNAP can convert to geographic
projections. If you plan to use a radar image into
a GIS system or as an additional band used in your
analysis, you should consider using images with the
highest level of processing (radiometrically corrected
(RTC) and science-ready), similar to the JAXA mosaics
but with a given date of acquisition.

Itis possible to see if images processed at a given
level are available for your region of interest. The
ASF website allows you to see data availability as a
function of processing level. Access this information
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Figure 1.7 The Vertex interface from ASF displays remote sensing data matching your search criteria. A
list of images with low-resolution thumbnails appear on the right-hand side. A single-click on the latter
produces the image footprint blue polygon on the map.

S 240k 70k 70k 30km
(i.e. image width)

Resolution 100 m 20m 10m 30m
Incidence angle 18-4327.1) 3430 34,30 21.50

(i.e. viewing geometry)

Table 1 Summary of ALOS/PALSAR-1 imaging mode characteristics.

Geographic projection Radar (SLC) Radar (SLC) Geographic Geographic

Multilook and calibrated
but with topographic
features; data equally
spaced on the ground

Equally-spaced single
look pixel in radar
coordinates

Radiometric format Single look pixel Science-ready

Table 2 Radar image processing levels. The radar single look complex (SLC) projection means “as the
radar” sees it (i.e., time of return of radar echoes), as opposed to a geographic coordinate projection.
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by clicking on https://www.asf.alaska.edu/sar-data/
palsar/alos-acquisition-maps/. You will be led to the
page shown in Figure 1.8. If you are interested in
ALOS/PALSAR-1 images that have been corrected for
the effect of terrain (radiometric terrain correction),
click on the last map icon to reach the page shown
in Figure 1.9.

4 RADAR DATA PROCESSING WITH SNAP

IIn this section, we will use the SNAP software to
open and display radar images, perform radiomet-
ric calibration, and filter the images to reduce speck-
le noise (for more information on speckle, refer to
Chapter 2 of this Handbook, section 2.1.5). We will
then manipulate data with GDAL and load, display
and perform analyses on the images in QGIS.

4.1 Read and Calibrate Data

To read in the images, let's begin processing with
Level 1.1 data. The 1.5 and RTC product data are
already processed. (Can you do better using SNAP,
bringing Level 1.1 to RTC?

To display the image, first, drag and drop the Level
1 file (either downloaded using the above steps or
use the included images in the data.zip file for this
training: ~ ALPSRP0733337100-L1.1-->VOL-ALPSR-
P073337100-H1.1__A) into the “Product Explorer”
window. Double click the file in “Product Explorer”,
then double click "Bands”, then click any “Intensity”
band. At this point, you should see your image within
the SNAP window as shown in Figure 1.10.

To calibrate the images:

« (o to the “Radar” menu at the top of the
screen. Click “Radiometric,” and then “Cali-
brate.”

«  Awindow will pop up. Here, specify the in-
put band and output file location.

* In the same window, click the “Processing
Parameters” tab. Select any “intensity”
band. Select beta0 band in order to obtain
radar backscatter as seen by the radar (i.e.
in its geometry).
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Figure 1.8 ASF coverage maps indicating the availability of ALOS-1 imagery for different processing levels.

ALOS PALSAR Radiometric Terrain Correction (RTC) Data Coverage

ALOS PALSAR Global Radar Imagery, 2006-2011

1h Map shows the total of ALOS PALSAR Radiometric Terrain Correction
(RTC) product coverage in the ASF archive
SATELLITE
FACILITY ALOS-PALSAR data are open access and can be downloaded using
ASF's Vertex data portal [vertex.daac.asf alaska.edul

Figure 1.9 Global availability of ALOS-1 radiometrically terrain corrected (RTC) imagery. The color ramp
indicates the number of available processed scenes.

THE SAR HANDBOOK


https://www.asf.alaska.edu/sar-data/palsar/alos-acquisition-maps/
https://www.asf.alaska.edu/sar-data/palsar/alos-acquisition-maps/

4.2 Apply Terrain Correction

The previous step calibrated the radiometry of the
images, given the instrument parameters. Now, we seek
to remove the impact of topography from the radar im-
age. This is often called “radiometric terrain flattening”.

Go to the “Radar” top menu and select “Radio-
metric”>"Radiometric Terrain Flattening.”

In the “Processing Parameters” tab, select “Beta0”
(See Figure 1.11). Click "Run”

Note this brings the image from Beta0 to Gam-
ma0 by removing topographic effects on the
backscatter.

4.3 Project Image to Ground Range

Up to this section, the images have been in radar
viewing geometry (often called “slant range”). We need
to convert this geometry to a geographic projection in
order to use the images for scientific analysis and other
applications. To perform the geographic projection:

Click “Radar” > "Geometric” > "Terrain Correc-
tion” > "Range-Doppler Terrain Correction”. A
window will pop up.

Select the input filtered band (the image you
want to reproject) and specify the output.

In “Processing parameters”, select Gamma0_
HH or Beta0. Ifyou want to get Gammao0 at this
step, it is time efficient and provides a terrain
flattened image.

Select the spatial resolution of output file (the
default is radar sampling), and save useful
bands, e.g,, “Selected source band”, “DEM",
“projected local incidence angle”

If after visual inspection, you realize that
ground projection is incorrect, use the “Ra-
dar” > "Geometric” > "Terrain Correction” >
"SAR-Simulation Terrain Correction” instead of
the “Range-Doppler Terrain Correction”. This
method uses a digital elevation model (DEM)
fo simulate a radar image that is subtracted
from the observed image. The DEM is automat-
ically downloaded.
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Figure 1.10 Viewing an intensity image in SNAP
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Figure 1.11 Radiometric Terrain Flattening (sometimes called “Radiometric Terrain Correction”) in SNAP.
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4.4 Converting from Linear Amplitude to
Decibels (dB)

Radar images consist of a wide range of values, with
more pixels at lower values. To compress this range,
improve image display, and reduce the impact of mul-
tiplicative noise, it is often preferred to represent image
values in decibels. To convert from linear (amplitude or
intensity) values to decibels (dB), click in the top menu:
“Raster”>"Data Conversion” > "Converts bands to/from
dB” and select the input band and output files. To write
the output, dlick "File” > "Export” > "Geaotiff".

5 USING QGIS TO ESTIMATE MANGROVE
BIOMASS

We will discuss two methods to estimate man-
grove biomass. The first will use canopy height
derived from a Digital Elevation Model (DEM). The
second method uses the radar backscatter images
generated in the previous exercise. As discussed in
Chapter 6 of the SAR Handbook, radar backscatter
is not a reliable indicator of biomass. Nonetheless,
it is worth learning about the technique. Mangrove
canopy height is well-estimated with digital eleva-
tion models derived from radar interferometry (e.g.
SRTM and TanDEM-X). We can obtain the Shuttle
Radar Topography Mission (SRTM) DEM from the
USGS Explorer website (Figure 1.13):

+  Goto: https://earthexplorer.usgs.gov/ and cre-
ate an account to download data

* In"Search Criteria”, click “Use Map”

+ (lick “Clear Coordinates”, and generate a poly-
gon for an area of interest (see Figure 13)

+  Gotothe"Data Sets" tab, and select the type of
data needed. The SRTM DEM will be found in
“Digital Elevation” > “SRTM". Use the “SRTM 1
Arc-Second Global”. Note the upcoming NASA-
DEM will not work for this purpose.

« (lick "Results” and select files for download.
Alternatively, instead of downloading the DEM
from earthexplorer.usgs.gov, you can use the
DEM_SRTM file in the data.zip folder provided
for this training.
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Figure 1.12 Projecting a radar image from slant range to ground range in SNAP.
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Figure 1.13 The USGS EarthExplorer interface
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5.1 Reading in and Displaying SRTM DEM
Data in QGIS

To visualize the DEM in QGIS, simply drag and drop
the DEM file (by default in .tif format) into QGIS (Figure
1.14). To adjust the colors, go to “properties” by right
clicking on DEM file name in QGIS under "Transparen-
¢y">"Additional value” = 0. You can set the background
to the Google Satellite image layer using the “XYZ Tiles"
setup, which is a QGIS plugin. Drag and drop available
bands on the left-hand side in QGIS to set the layer or-
der, with the basemap below the band information lay-
ers. Finally, to select an area with mangroves, open the
mangrove shapefile that can be found in the data.zip file
(Mangroves > africa_mangrove.shp).

5.2 Loading in polygons to clip a raster in
QGIS

This section explains how to use existing polygons
(e.g. shapefiles) to extract values from a raster image.
Follow the steps below:

+  Drag and drop the mangrove shapefile into
QGIS (Figure 1.15). You can change the polygon
display color via a right click > “Properties”

+ Cutthe SRTM DEM with a polygon: Via the top

menu; “Raster” > "extraction” > "Clip Raster by
Mask Layer”

If QGIS fails to clip the SRTM DEM, you may need to
use the command line. Copy and paste this text into a
terminal window:

gdalwarp -ot Float32 -of GTiff -tr

0.00027778 -0.00027778 -tap -cut-

line /YourDirectoryWithShape-

File/africa_mangrove_withindem.

shp -crop_to_cutline -dstno-

data 0.0 / YourDirectoryWithS-

RTM /s05_e039_larc_v3.tif /

YourDirectoryWithOutputs /

s05_e039_larc_v3_mangroves.tif

You now have a canopy height map. With SRTM, el-
evation corresponds to basal area weighted height (also
called Lorey's height). The maximum height is generally
1.6X this value. (Simard et al., 2019). See the results in
Figure 1.15.
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Figure 1.14 View of the SRTM DEM overlaid on the Google Satellite baselayer in QGIS.

Figure 1.15 View of mangrove extents from an existing polygon (left) and via corresponding canopy
height (right).
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5.3 Applying the Generic Height-Based
Allometric Equation BV L
[:]

In this section, we will estimate mangrove biomass .5,
using canopy height estimates from SRTM DEM. This =/
can be easily achieved applying the allometric equation | z s
directly to the DEM. There are several genericequations | @ee:

Rastor bands

relating SRTM to canopy height and aboveground bio- " & we:™ - LT — o et ]
mass (Simard etal., 2019): @ wcdssene AL o

*  Basal area weighted height: H,, ~1.08*SRTM - = ”W

* Maximumcanopyheight:H__ ~0.93*1.7*SRTM : w::n:f

* Aboveground Biomass: B~3.25"H,_'** M'm;ﬂw*_;m
To apply the allometric equation, follow these steps: _

o
In QGIS, click on “Raster” in the top menu, then "Ras- "

ter Calculator” (see Figure 1.16) T ome

* Define the output layer filename, location and
format (Geotiff is a favorite)

. Enter the a”ometnc equa“on for SRTM 1 Tyoe o ocats KK  1legond evtries ramoved. Cooreieata 4380750, -502202 | @5 | Bowe[1107,565 [~ | i | Mageitioe[100% |-} Metaeion [00° ][] I Rencer| #® EpScidasT | @
B=3.25"H,, '** where H_=1.08"SRTM, and [ _
be ; BERA DSBS S RO P AHLEIBAS
the equation becomes 3.25%(1.08*SRTM)"*3 BEV. AW
(1] e
+ 2 Y %0
5.4 Applying the Generic Backscatter-Based | ==~
Allometric Equation e

In this section, we will estimate mangrove biomass | Z:=*
from radar backscatter. Keep in mind this method does ~ |* Zxzr

@ wes
not work very well for mangrove forests, as site-specific w”,s.,.,
allometry may be required. Here are generic (ie. tai- | e

lored to tropical forests) equations relating aboveground
biomass B in tons per hectare (t/ha) to backscatter in
decibels (dB): e

o g, (dB)--225+30* In(B) at
W

4 B v00_0039_tar_va_mengroves

o

+ ¢, (linear)~a.Ba' (1-e")+ ¢, where .
a=0.013682, a'=0.21116, b=0.051845, =
=0.02192 (Yu & Saatchi, 2016). To
simplify, use B(t/ha) = 0.5x101“0-2
with s°,. in linear units (m?/m?)

* & [ Coogle Satellite Hybrid

| thegand eniries semeest Cosrdinate 2366008 537652 | B | Scale [1907.965 =] & | Mg [100% ) Rotstien [0.0° 5] i mender ® EDSO:IEST @

Note: There is no definitive relationship for mangroves
because of their intermittent inundation and increased
root absorption at high biomass levels. However, the
logarithmic geometry remains. To apply these equations
to the science-ready radar images:

Figure 1.16 The results of performing band math within QGIS to obtain estimates of mangrove biomass.
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1. Upload either your SNAP-processed
radar images (in dB), or the ALOS-PAL-
SAR mosaic (found in the data.
z7ip folder provided for this training;
ALOS_Mosaic-20190325T215536Z-001)
into QGIS (Figure 1.17).

Note: For simplicity and efficiency, let's use the JAXA
ALOS mosaics for this exercise. Remember to convert
the mosaics’ digital number (DN) value to dB using the
following JAXA-provided formula:

5, (dB) = 20"log, (DN) - 83

2. In the top menu, click "Raster”, then “Raster
Calculator”.

3. Enter the formula in "Raster Calculator Expres-
sion”. Double-click on the band name to insert
an expression.

4, The JAXAformula to convert DN to dB results in
images that are in dB. However, the allometric
equation that we used is in linear units. Always
be aware of units used, as biomass allometry
could also be using dB.

5. Intop menu, dlick on "Raster” and then “Ras-
ter Calculator”. Enter the allometric equation
via the “Raster Calculator Expression”, i.e.
0.5*10(40.2*"Rasterlmage”) with “Rasterlm-
age” in linear units (m?/m?). That means that
if using a dB image, the equations become:
0.5"10%(40.2°10"("Rasterlmage"/10))

1. 6. Use the same mangrove shapefile you used
in the SRTM DEM portion of the exercise to ex-
tract the mangrove extent from the image. Use
an older version of QGIS (currently not working
in 3.0 and 3.2) or copy/paste the following into
your terminal window to obtain Figure 1.18:

gdalwarp -ot Float32 -of GTiff -tr
0.0002222 -0.0002222 -tap -cut-
line /DirectoryWherePolygonLocat-
ed/africa_mangrove_withindem.shp
-crop_to_cutline /DirectoryWhere-
BiomassTransformedImageIsLocated/
S04E039 07_sl_HV_bcksctr_ AGB.tif /
YourOutputDirectory/S04E039_07_
sl_HV_bcksctr_ AGB_mangroves.tif
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Figure 1.17 ALOS-1 JAXA mosaic using HV polarization.
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Figure 1.18 Aboveground biomass obtained from the backscatter curve. Clearly, the retrieved biomass
is much lower than that obtained with SRTM. Backscatter is known to be limited in mangrove forest,
changing with water level and mangrove types, sometimes decreasing at biomass above 100t/ha in red
mangroves. You may have to derive your own site-specific allometric equation relating biomass to either
height or backscatter (See the next section for further information).
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5.5 Deriving Your Own Allometric Equations

To derive site-specific allometric equations relating
canopy height or radar backscatter to in situ biomass, we
must obtain field data with latitude, longitude and bio-
mass values, which can be formatted into columns of a
.Csv (comma-separated values) delimited text file. Once
the data is formatted as a .csv, it can be taken into QGIS
to extract radar image or interferometric height values:

1. Savethe data asa .csvfile.

2. Readinto QGIS: Inthe top menu: click “Layer”>
"Add Layer”>"Add Delimited Text Layer”. Then
navigate to your CSVfile and follow the instruc-
tions. You may need to specify the projection
in “Geometry”.

3. Ifyou have installed the QGIS “Point Sampling
Tool” plugin, click on its icon and select your
CSV layer.

4. Selectthe attributes youwantto preserve in the
output file. These must include, for example,
biomass and backscatter.

5. Define your “Output point vector layer”. Via the
pop-up window, select “Comma Separated
Values (*.csv)" as the output format.

6. Openyournew CSVfile in Excel and fitan equa-
tion.

7. In QGIS, apply the new equation to the radar
backscatter image using the “Raster Calculator”,
as explained in section 5.4.

8. Atthis point, you can independently generate
your own biomass map.

9. Using this same method, you can also validate
your biomass maps using available field data.

5.6 Monitoring Mangrove Forest Loss and
Gain

While radar backscatter is not the best variable for
estimating biomass in mangrove forests, one can use
it to monitor mangrove forest loss and gain over time.
To do this, you need to open several images into QGIS
and use either band math to subtract images and detect
change, or a 3-image color composite to visualize chang-
es. Let'stry the latter first:
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Figure 1.19 Generating a “virtual raster” from 3 bands to make a color composite image representing

change over time.

1. Load 3 images from different times into
QGIS, e.g. JERS-1 (1996), ALOS-1(2007) and
ALOS-2 (2017) mosaic tiles.

2. From the top menu, click “Raster” > "Miscel-
laneous” > "Build Virtual Raster”. A window
pops-up (See Figure 1.19)

3. Select the output parameters, for example,
“resolution”=highest. In the “Advanced pa-
rameters” tab, select “Bilinear” (note that
this may decrease resolution slightly). Select
bands by clicking on “Input layers".

Note the default band order. To change the order,
use the temporary file called “buildvrtinputFiles.
txt" generated by QGIS, which is shown in the
"GDAL/OGR console call” frame. Copy and edit
that file. You can relaunch the virtual raster from
the command line using your newly-edited file.

4. Be sure to select the “Place each input file
into a separate band” box, and click “Run”.

You can load the virtual raster into QGIS and change

colors using the “Properties” menu by right clicking on
the virtual raster. Then, set all bands to the same range
of values. In dB, this should be around -20 and -5, and
-25 and -10 for HH and HV respectively. You now have
a picture where colors represent change between im-
ages (Figure 1.20). Ifred, change occurred between
the first input band and the others. If green, change
occurred only for the 2nd band. (i.e. change occurred
between band 1and 2; however, change again may be
returning to original land cover between image 2 and
3.) If blue, there may have been some regeneration.
Note: because we used HH (1996 mosaic only has HH),
the radar signal is strongly impacted by soil moisture
and inundations.  Overall, the color changes seen
here are in agricultural areas and observed changes
may be due to crop maturity at the time of imaging.
To accurately monitor changes, generate your time-Se-
ries from either ALOS or Sentinel-1 time-series data via
SNAP. You can choose acquisition dates corresponding
to plant phenology and climatic trends. We found no
significant changes in mangrove forests for the study
region. Did you?
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RGB image composite of 1997, 2007 and 2017.
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5.7 Determining change areas with simple
thresholds

While a more thorough statistical analysis will pro-
vide additional insight on gain and loss uncertainty, the
extent of change (e.g. loss) can be determined by a sim-
ple threshold. In QGIS, use "Raster”>"Raster Calculator”
to compute the difference image between two datasets
from differentyears. We will use ALOS 2007 minus 1996
as a test of a small area of change in a forest. To deter-
mine a threshold that will indicate whether an area has
changed or not, we can begin with a visual analysis. If
you find an area that has changed, you can draw a poly-
gon around it and used the observed statistics of the dif-
ference image to determine the appropriate threshold.

To draw the polygon of observed change, follow these
steps:

",

* Inthetop menu, dlick “Layer”>
"New Shapefile Layer”

Create Layer”>

* Define the “Geometry Type” as “polygon’”.

* Define the output filename in “File Name” and
in “New Field", use whole numbers. We'll use
1for change.

* Inthe “Layers” window, click on this new layer.

« Inthe top menu, click "Layer” > "Toggle Edit-
ing”. You can now add features within the file
by clicking in the top menu: “Edit” > "Add poly-
gon feature”.

« Draw a polygon around observed changes in
the difference map with a mouse dlick on the
vertices of the polygon. To finish the polygon
geometry, right click. Don't forget to Save your
changes by dlicking “Toggle Editing” again.

To populate the polygons with attribute values
containing statistics from the difference image, use
“SAGA" in the toolbox. To see the toolbox, dlick “Pro-
cessing” in the top menu and then “Toolbox”. Navi-
gate to “SAGA” > "Vector-Raster” > "Raster Statistics
for polygons”.

+ Select the difference image for “Grids”, then
your change polygon for “Polygons”, and select
your favorite statistical parameters (include
mean and standard deviation). You should use
these values to Select the threshold that deter-

mines if a change has occurred or not.

You can also train areas that have not changed to
improve performance and prepare for an accuracy
assessment.

+  Anew polygon band is created with the stats as
an attribute. Right dlick on the new band and
select view “Attribute table”.

Then, use “Raster” > “Raster Calculator” to make a
change map. The equation can, for example, have the
following form: ("S04E039_07minus96@1"<-7.0) and
("S04£039_07_s|_HH_dB@1">-15). The logical opera-
tors (<, >, and, etc) select all values smaller than -7 (i.e.
change) that are above -15 in 2007. The latter condition
removes some water surfaces when using HH. Optional-
ly, you can build your own water mask and use itinstead.
To clean up the change map, use the “Majority Filter”
found in “SAGA” > "Raster Filter”. Afilter of radius 1 is
sufficient to remove false changes that may results from
radar speckle noise. Tryagain, but filter the radar images
with the “Multidirectional Lee Filter” found in “SAGA” >
"Raster Filter”.

Figure 1.21 shows the resulting change map over-
laid on Google Earth imagery. In this case, a road seems
to have been constructed between 1996 and 2007,
which may have led to further forest disturbance after
2007.

6 TRAINING MODULE SUMMARY

After completing this training module, you have suc-
cessfully:

1. Processed raw level 1.1 ALOS images using the
ESA Sentinel toolbox (SNAP):

« Opened, displayed, and calibrated images
*  Radiometric terrain flattening
+  Ground registration
«  Performed image filtering
2. |dentified archives of radar datasets:

«  ASF(ALOS and Sentinel), JAXA (ALOS mosaics),
NASA/USGS (SRTM DEM, etc)

3. Performed data processing and analysis in QGIS:

«  (utimages to mangrove polygons

Figure 1.19 Land use change (disturbance map)
produced with threshold calculations on time-

series imagery.
* Manually generated polygons delineating
features of interest

+ Derived statistics to populate polygon attri-
butes

+  (onverted radar images to dB

+  Filtered raster images

+ Performed computations with raster layers

+  Displayed resultant color-composite images
4. Estimated biomass

« Used SRTM DEM to estimate canopy height
and biomass of mangrove forests (Note:
You can also use DEMs from other sensors,
such as TanDEM-X)

*  Used ALOS backscatter to estimate man-
grove biomass (with limited accuracy)

5. Used radar backscatter from different time peri-
ods (e.g. 1996, 2007 and 2017) to map land cover
change

« Wedid not find significant loss in the man-
grove forests examined, but did test the
methodology on inland forests
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